Mani's Blog

March 1, 2011

>Oracle:Agent is Running but Not Ready

Filed under: Oracle — mani @ 1:12 am
Tags: ,

> My Oracle agent was not responding well.  I had to run following fixes to make it run.
1. Stop target agent host
<AGENT_HOME>/bin/emctl stop agent

2. On Verify no emagent process are running
ps -ef|grep emagent

3. Clean up old residue files
cd <AGENT_HOME>/sysman/emd
rm -rf agntstmp.txt
rm -rf lastupld.xml
rm -rf recv/*
rm -rf collection/*
rm -rf upload/*
rm -rf state/*

4. Secure Agent
<AGENT_HOME>/bin/emctl secure agent

5. Start Agent
<AGENT_HOME>/bin/emctl start agent

6. Set Clearstate for Agent
<AGENT_HOME>/bin/emctl clearstate agent

7. Upload data for agent
<AGENT_HOME>/bin/emctl upload agent

8. Run status for agent
<AGENT_HOME>/bin/emctl status agent

Advertisements

1 Comment »

  1. Wow that was unusual. I just wrote an incredibly long comment but after I clicked submit
    my comment didn’t appear. Grrrr… well I’m not writing all
    that over again. Anyhow, just wanted to say great blog!

    Comment by Kevin — December 14, 2012 @ 1:38 am | Reply


RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

%d bloggers like this: